CyberCity ADSL using a Cisco SOHO 77

While debugging connectivity issues on my recently installed CyberCity ADSL line, I came to suspect the ZyXEL router supplied to me by the ISP.

Erwin kindly offered to lend me a good old Cisco SOHO 77 ADSL router to test with, which meant I had to find out how to actually configure this device for use with CyberCity.

It didn’t take long, though – below my configuration for reference:

  • dsl654321 is my CyberCity user name
  • 11.22.33.44 is my public IP address
  • The example configuration contains a static PAT for all ports to 192.168.0.2
Current configuration : 2137 bytes
!
version 12.3
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname dsl654321
!
boot-start-marker
boot-end-marker
!
logging buffered 8192 debugging
enable secret 5 **removed**
!
clock timezone CET 1
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
ip subnet-zero
ip domain lookup source-interface Loopback0
ip name-server 212.242.40.3
ip name-server 212.242.40.51
!
ip dhcp pool soho77
   network 192.168.0.0 255.255.255.0
   dns-server 212.242.40.3 212.242.40.51
   default-router 192.168.0.1
   lease 0 1
!
interface Loopback0
 ip address 192.168.255.1 255.255.255.0
!
interface Tunnel0
 no ip address
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 no keepalive
 no cdp enable
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode ansi-dmt
 pvc 0/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
interface Dialer0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp chap hostname dsl654321
 ppp chap password 7 **removed CyberCity Password**
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static 192.168.0.2 11.22.33.44 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.255.255
dialer-list 1 protocol ip permit
no cdp run
snmp-server engineID local 000000090200000427FD16B9
snmp-server community **removed** RO
snmp-server enable traps tty
banner motd ^C
***************************************
*                                     *
*   UNAUTHORISED ACCESS PROHIBITED    *
*                                     *
***************************************
^C
!
line con 0
 exec-timeout 60 0
 password 7 **removed**
 login
 transport output all
 stopbits 1
line vty 0 4
 exec-timeout 60 0
 password 7 **removed**
 login
 transport input all
 transport output all
!
scheduler max-task-time 5000
sntp server 212.242.32.206
end

2 thoughts on “CyberCity ADSL using a Cisco SOHO 77”

  1. Before I got Fiber to the Home, I had a ZyXEL Prestige 642R for ADSL. Which I never had trouble with, other than sometimes having to reboot it after the link had gone down and the modem showed LCP errors (I guess sometimes it didn’t recognize that everything was okay again).

  2. This is a ZyXEL Prestige 660HW-D1 (actually, it’s my second 660HW-D1 – CyberCity kindly sent me a new one after a technician had measured the raw copper phone line as being “nearly perfect”).

    My connection problem remains, though – even with the Cisco SOHO 77 – so I’m guessing the problem lies at the DSLAM (which means I’ll have to make yet another call to CyberCity support :-))

Leave a Reply

Your email address will not be published. Required fields are marked *